Skip to main content

volume of sphere and hemisphere in Python | program

 volume of sphere and hemisphere.

  • Volume of hemisphere = 2Ï€r3/3, where 'r' is the radius of the hemisphere.
  • Volume of sphere = 4Ï€r3/3, where 'r' is the radius of the sphere.

Program to find volume of sphere and hemisphere

Input :

enter radius of sphere 4
enter radius of hemisphere 4

Output :

volume of sphere is %.2f 268.08
volume of hemisphere is  134.04

# Program to find volume of sphere and hemisphere
# for pi use pi value as 3.1423 or import math module
from math import*
#Program to find volume of sphere
radius1 = float(input("enter radius of sphere "))
vol_sphere = (4*pi*radius1*radius1*radius1)/3
print("volume of sphere is %.2f",round(vol_sphere,2))
#Program to find volume of hemisphere
radius2 = float(input("enter radius of hemisphere "))
vol_hemisphere = (2*pi*radius2*radius2*radius2)/3
print("volume of hemisphere is ",round(vol_hemisphere,2))
#here round(var,n) is predefined function used to get n digits after point

Output :

enter radius of sphere 4
volume of sphere is %.2f 268.08
enter radius of hemisphere 4
volume of hemisphere is  134.04
> 

Comments

Popular posts from this blog

Day 7: Arrays | HackerRank | solution in python

Objective Today, we will learn about the  Array  data structure. Check out the Tutorial tab for learning materials and an instructional video. Task Given an array,  , of   integers, print  's elements in  reverse  order as a single line of space-separated numbers. Example Print  4 3 2 1 . Each integer is separated by one space. Input Format The first line contains an integer,   (the size of our array). The second line contains   space-separated integers that describe array  's elements. Constraints Constraints , where   is the   integer in the array. Output Format Print the elements of array   in reverse order as a single line of space-separated numbers. Sample Input 4 1 4 3 2 Sample Output 2 3 4 1 Python Program  #PROGRAM IN PYTHON import math import os import random import re import sys if __name__ == '__main__': n = int(input()) arr = list(map(int, input().rstrip().split())) for i in arr: b=arr[::-1] for i in b: print(i,end=' ') Input : 4 14

Day 0: Hello, World. | HackerRank || Python3

Objective In this challenge, we review some basic concepts that will get you started with this series. You will need to use the same (or similar) syntax to read input and write output in challenges throughout HackerRank. Check out the Tutorial tab for learning materials and an instructional video!  Task  To complete this challenge, you must save a line of input from stdin to a variable, print Hello, World. on a single line, and finally print the value of your variable on a second line. You've got this!   Note:  The instructions are Java-based, but we support submissions in many popular languages. You can switch languages using the drop-down menu above your editor, and the variable may be written differently depending on the best-practice conventions of your submission language.   Input Format  A single line of text denoting (the variable whose contents must be printed).  Output Format   Print Hello, World. on the first line, and the contents of on the second line.   Sample Inpu

Day 5: Loops | HackerRank | solution in python.

Objective In this challenge, we will use loops to do some math. Check out the Tutorial tab to learn more. Task Given an integer,  , print its first   multiples. Each multiple   (where  ) should be printed on a new line in the form:  n x i = result . Example The printout should look like this: 3 x 1 = 3 3 x 2 = 6 3 x 3 = 9 3 x 4 = 12 3 x 5 = 15 3 x 6 = 18 3 x 7 = 21 3 x 8 = 24 3 x 9 = 27 3 x 10 = 30 Input Format A single integer,  . Constraints Output Format Print   lines of output; each line   (where  ) contains the   of   in the form: n x i = result . Sample Input 2 Sample Output 2 x 1 = 2 2 x 2 = 4 2 x 3 = 6 2 x 4 = 8 2 x 5 = 10 2 x 6 = 12 2 x 7 = 14 2 x 8 = 16 2 x 9 = 18 2 x 10 = 20 #PROGRAM IN PYTHON import math import os import random import re import sys if __name__ == '__main__': n = int(input()) for i in range(1,11): print(n,"x",i,'=',n*i)