Skip to main content

Program to find leap Year or not in Python

 What is a Leap year ?

Generally  we have 28 days in the month of February and overall 365 days in a year. But a leap year have 29 days in the month of February and overall 366 days in a year. For every four years we get a leap year.

Conditions to be a leap Year.

Year divisible by 4 is a leap year until it is not divisible by 100 (century year{year ends with 00} is not a leap year until it is divisible by 400, if it is divisible by 400 then it is a leap year.

Explanation : 

  • For a non century year  if year divisible by 4 then it is a leap year.

    For a non century year  if year not divisible by 4 then it is not a leap year.

  • If year is a century year then it is not a leap year.

  • Century year is said to be a leap year if it is divisible by 400 .

Input :

enter a year 2400

Output : 

2400 is a leap year 

Program to find leap Year or not in Python


#program to say leap year or not
year=int(input("enter a year "))
if year%4==0:
    if year%100==0:
        if year%400==0:
            print(year,"is a leap year.")
        else:
            print(year,"is not a leap year.")
    else:
        print(year,"is a leap year.")
else:
    print(year,"is not a leap year.")
    
#----method 2------using ternary operator---------#
year=int(input())
print("leap year"if (year%4==0) else "not a leap year")

Output :

enter a year 2400
2400 is a leap year.

Comments

Popular posts from this blog

Day 7: Arrays | HackerRank | solution in python

Objective Today, we will learn about the  Array  data structure. Check out the Tutorial tab for learning materials and an instructional video. Task Given an array,  , of   integers, print  's elements in  reverse  order as a single line of space-separated numbers. Example Print  4 3 2 1 . Each integer is separated by one space. Input Format The first line contains an integer,   (the size of our array). The second line contains   space-separated integers that describe array  's elements. Constraints Constraints , where   is the   integer in the array. Output Format Print the elements of array   in reverse order as a single line of space-separated numbers. Sample Input 4 1 4 3 2 Sample Output 2 3 4 1 Python Program  #PROGRAM IN PYTHON import math import os import random import re import sys if __name__ == '__main__': n = int(input()) arr = list(map(int, input().rstrip().split())) for i in arr: b=arr[::-1] for i in b: print(i,end=' ') Input : 4 14

Day 0: Hello, World. | HackerRank || Python3

Objective In this challenge, we review some basic concepts that will get you started with this series. You will need to use the same (or similar) syntax to read input and write output in challenges throughout HackerRank. Check out the Tutorial tab for learning materials and an instructional video!  Task  To complete this challenge, you must save a line of input from stdin to a variable, print Hello, World. on a single line, and finally print the value of your variable on a second line. You've got this!   Note:  The instructions are Java-based, but we support submissions in many popular languages. You can switch languages using the drop-down menu above your editor, and the variable may be written differently depending on the best-practice conventions of your submission language.   Input Format  A single line of text denoting (the variable whose contents must be printed).  Output Format   Print Hello, World. on the first line, and the contents of on the second line.   Sample Inpu

Day 5: Loops | HackerRank | solution in python.

Objective In this challenge, we will use loops to do some math. Check out the Tutorial tab to learn more. Task Given an integer,  , print its first   multiples. Each multiple   (where  ) should be printed on a new line in the form:  n x i = result . Example The printout should look like this: 3 x 1 = 3 3 x 2 = 6 3 x 3 = 9 3 x 4 = 12 3 x 5 = 15 3 x 6 = 18 3 x 7 = 21 3 x 8 = 24 3 x 9 = 27 3 x 10 = 30 Input Format A single integer,  . Constraints Output Format Print   lines of output; each line   (where  ) contains the   of   in the form: n x i = result . Sample Input 2 Sample Output 2 x 1 = 2 2 x 2 = 4 2 x 3 = 6 2 x 4 = 8 2 x 5 = 10 2 x 6 = 12 2 x 7 = 14 2 x 8 = 16 2 x 9 = 18 2 x 10 = 20 #PROGRAM IN PYTHON import math import os import random import re import sys if __name__ == '__main__': n = int(input()) for i in range(1,11): print(n,"x",i,'=',n*i)