Skip to main content

Printing first n even and odd numbers in Python using for loop

for Loop in Python

  • for loop -- Executes a sequence of statements multiple times and abbreviates the code that manages the   loop variable.

even and odd numbers

  • An even number is a number that can be divisible by 2.
  •  Even numbers are  2, 4, 6, 8 and so on.
  •  An odd number is a number that cannot be divisible by 2.
  • Odd numbers are 1, 3, 5, 7, 9 so on.
Program to print first 10 even and odd numbers using for  loop.

Input :

how many even and odd nums you want 5

Output :

first 5 even nums are 
2 4 6 8 10 
first 5 odd nums are 
1 3 5 7 9


# Program to print first n even and odd numbers using for  loop.
choice = int(input("how many even and odd nums you want "))
n=(choice*2)+1
print("first",choice,"even nums are ")
for i in range(1,n):
    if i%2 == 0:
        print(i,end=" ")
print("\nfirst",choice,"odd nums are ")
for i in range(1,n):  
    if i%2!=0:
        print(i,end=" ")

Output :

first 5 even nums are 
2 4 6 8 10 
first 5 odd nums are 
1 3 5 7 9

Comments

Popular posts from this blog

Python Addition | Substration | Multiplication | Division | Modulous | in python

Addition (+)  Substraction (-)  Multiplication (*)  Division (/)(//)  Modulus (%)   Input :  first num 20 second num 10 Output :  Addition is  30 substraction is  10 multiplication is 200 float division  2.0 integer division  2 remainder is  0 PROGRAM IN PYTHON num1=int(input("first num ")) num2=int(input("second num ")) #sum of two numbers sum_of_two = num1 + num2 print("Addition is ",sum_of_two) #substitution of two sub_of_two = num1 - num2 print("substitution is ",sub_of_two) #multiplication of two nums sub_of_two = num1 * num2 print("multiplicatio is ",sub_of_two ) #division of two nums div_of_two1 = num1 / num2 #float division div_of_two2 = num1 // num2 #integer division print("float division ",div_of_two1) print("integer division ",div_of_two2) #modulus of two mod_of_two = num1 % num2 print("remainder is ",mod_of_two) output IN PYTHON first num 20 second num 10 Addition is 30 substitution is...

Day 10: Binary Numbers | HackerRank | solution in python

Objective Today, we're working with binary numbers. Task Given a base-  integer,  , convert it to binary (base- ). Then find and print the base-  integer denoting the maximum number of consecutive  's in  's binary representation. When working with different bases, it is common to show the base as a subscript. Example The binary representation of  ...

Day 5: Loops | HackerRank | solution in python.

Objective In this challenge, we will use loops to do some math. Check out the Tutorial tab to learn more. Task Given an integer,  , print its first   multiples. Each multiple   (where  ) should be printed on a new line in the form:  n x i = result . Example The printout should look like this: 3 x 1 = 3 3 x 2 = 6 3 x 3 = 9 3 x 4 = 12 3 x 5 = 15 3 x 6 = 18 3 x 7 = 21 3 x 8 = 24 3 x 9 = 27 3 x 10 = 30 Input Format A single integer,  . Constraints Output Format Print   lines of output; each line   (where  ) contains the   of   in the form: n x i = result . Sample Input 2 Sample Output 2 x 1 = 2 2 x 2 = 4 2 x 3 = 6 2 x 4 = 8 2 x 5 = 10 2 x 6 = 12 2 x 7 = 14 2 x 8 = 16 2 x 9 = 18 2 x 10 = 20 #PROGRAM IN PYTHON import math import os import random import re import sys if __name__ == '__main__': n = int(input()) for i in range(1,11): print(n,"...