Skip to main content

Area and Perimeter of Rectangle in python | program in python

 Area and Perimeter of a Rectangle.


All rectangles are also parallelograms, but not all parallelograms are rectangles. The perimeter P of a rectangle is given by the formula, P=2l+2w  or 2(l + w), where l is the length and w is the width of the rectangle. The area A of a rectangle is given by the formula, A=l*w , where l is the length and w is the width.

Input :

enter length 12
enter breadth 10

Output:

area is 120
perimeter is 44

Program to find area and perimeter of a rectangle.


#program to print area and perimeter of rectangle.  
length = int(input("enter length "))
breadth = int(input("enter breadth "))
#area of rectangle = l*b
area = length * breadth
print("area is ",area)
#perimeter of rectangle= 2(l+b)
perimeter=2*(length+breadth)
print("perimeter is ",perimeter)

Output :

enter length 12
enter breadth 10
area is  120
perimeter is  44

Comments

Popular posts from this blog

Day 7: Arrays | HackerRank | solution in python

Objective Today, we will learn about the  Array  data structure. Check out the Tutorial tab for learning materials and an instructional video. Task Given an array,  , of   integers, print  's elements in  reverse  order as a single line of space-separated numbers. Example Print  4 3 2 1 . Each integer is separated by one space. Input Format The first line contains an integer,   (the size of our array). The second line contains   space-separated integers that describe array  's elements. Constraints Constraints , where   is the   integer in the array. Output Format Print the elements of array   in reverse order as a single line of space-separated numbers. Sample Input 4 1 4 3 2 Sample Output 2 3 4 1 Python Program  #PROGRAM IN PYTHON import math import os import random import re import sys if __name__ == '__main__': n = int(input()) arr = list(map(int, input().rstrip().split())) for i in arr: b=arr[::-1] for i in b: print(i,end=' ') Input : 4 14

Day 0: Hello, World. | HackerRank || Python3

Objective In this challenge, we review some basic concepts that will get you started with this series. You will need to use the same (or similar) syntax to read input and write output in challenges throughout HackerRank. Check out the Tutorial tab for learning materials and an instructional video!  Task  To complete this challenge, you must save a line of input from stdin to a variable, print Hello, World. on a single line, and finally print the value of your variable on a second line. You've got this!   Note:  The instructions are Java-based, but we support submissions in many popular languages. You can switch languages using the drop-down menu above your editor, and the variable may be written differently depending on the best-practice conventions of your submission language.   Input Format  A single line of text denoting (the variable whose contents must be printed).  Output Format   Print Hello, World. on the first line, and the contents of on the second line.   Sample Inpu

Day 5: Loops | HackerRank | solution in python.

Objective In this challenge, we will use loops to do some math. Check out the Tutorial tab to learn more. Task Given an integer,  , print its first   multiples. Each multiple   (where  ) should be printed on a new line in the form:  n x i = result . Example The printout should look like this: 3 x 1 = 3 3 x 2 = 6 3 x 3 = 9 3 x 4 = 12 3 x 5 = 15 3 x 6 = 18 3 x 7 = 21 3 x 8 = 24 3 x 9 = 27 3 x 10 = 30 Input Format A single integer,  . Constraints Output Format Print   lines of output; each line   (where  ) contains the   of   in the form: n x i = result . Sample Input 2 Sample Output 2 x 1 = 2 2 x 2 = 4 2 x 3 = 6 2 x 4 = 8 2 x 5 = 10 2 x 6 = 12 2 x 7 = 14 2 x 8 = 16 2 x 9 = 18 2 x 10 = 20 #PROGRAM IN PYTHON import math import os import random import re import sys if __name__ == '__main__': n = int(input()) for i in range(1,11): print(n,"x",i,'=',n*i)